Scheduled for August 14, 2025 at 7:00 AM – 8:00 AM
Affects
Main Services
Under maintenance from 7:00 AM to 8:00 AM
Public Server
Under maintenance from 7:00 AM to 8:00 AM
Completed
August 14, 2025 at 8:00 AMCompleted
August 14, 2025 at 8:00 AMMaintenance has completed successfully
Update
August 14, 2025 at 7:43 AMUpdate
August 14, 2025 at 7:43 AMMaintenance has been extended while we wait for a custom match to end. Sorry for the delay!
In progress
August 14, 2025 at 7:00 AMIn progress
August 14, 2025 at 7:00 AMMaintenance is now in progress
Planned
August 14, 2025 at 7:00 AMPlanned
August 14, 2025 at 7:00 AMWe are executing a scheduled network reboot to deploy updated code to the proxies. We allow all games to end without allowing new players to join, so the network will be unreachable for about 45 minutes.